问题:

我正在尝试在Xcode中生成UItest。 当我尝试刷UIview时出现错误:

Timestamped Event Matching Error: Failed to find matching element

错误窗口

在此输入图像描述

如果我尝试点击UIView,也会发生这种情况。

I’m trying to generate a UItest in Xcode.When I try to swipe UIview I get an error:error windowThis also happens if I try to tap UIView.

问题:

切入追逐我已经重新创建了我的问题,因为它是相当自我解释的。

这符合,没有错误:

switch (n) {
    case 1:
        NSLog(@"");
        NSString *aStr;
        break;
    default:
        break;
    }

这编译错误 ,它只缺少NSLog():

switch (n) {
    case 1:
        NSString *aStr;
        break;
    default:
        break;
    }

它在编译时出现错误“NSString’之前的预期表达式

我在这里错过了什么吗?

Cut to the chase I have recreated my problem as it is fairly self explanatory.this complies without error:this compiles with error and it’s only missing the NSLog():it throws an error at compile ” Expected expression before ‘NSString’ “Am I missing something here?

问题:

第一次启动该应用程序时,一切似乎运行良好。 我将按一下“停止”按钮,做一些工作,当我再次启动它时,它似乎崩溃了,甚至无法加载任何东西。 按停止,再次单击运行,它可以正常工作。 直到我重复该过程。

这是xcode使用“线程1:信号SIGABRT”突出显示错误的地方。 显然这里没有用。

int main(int argc, char *argv[])
{
    @autoreleasepool {
        return UIApplicationMain(argc, argv, nil, NSStringFromClass([PokerAppDelegate class]));
    }
}

调试控制台除了(lldb)之外什么都没有显示(因此,我想它停止了,目前还没有崩溃)。因此,当我执行BT这就是我得到的:

(lldb) bt
* thread #1: tid = 0x1c03, 0x9a258a6a libsystem_kernel.dylib`__pthread_kill + 10, stop reason = signal SIGABRT
    frame #0: 0x9a258a6a libsystem_kernel.dylib`__pthread_kill + 10
    frame #1: 0x99ea1b2f libsystem_c.dylib`pthread_kill + 101
    frame #2: 0x04a7057b libsystem_sim_c.dylib`abort + 140
    frame #3: 0x01dc0b4e GraphicsServices`GSRegisterPurpleNamedPort + 348
    frame #4: 0x01dc069f GraphicsServices`_GSEventInitialize + 123
    frame #5: 0x01dc0c1f GraphicsServices`GSEventInitialize + 36
    frame #6: 0x000163f9 UIKit`UIApplicationMain + 600
    frame #7: 0x00001d0d Guitar Chord Poker HD`main(argc=1, argv=0xbffff32c) + 141 at main.m:16
    frame #8: 0x00001c35 Guitar Chord Poker HD`start + 53
(lldb) 

到目前为止,这是我所做的:

  • 执行“清洁”
  • 我已经重置了模拟器并重置了计算机
  • 我已经注释掉了视图控制器中的所有代码,仍然崩溃
  • 我已注释掉应用程序委托中的所有代码,仍然崩溃
  • 但是…。我已经在Xcode以外的设备上运行了该应用程序,并且看起来运行得很好。
  • (编辑)我已经从各种缓存文件夹中删除/重新安装了xcode和所有内容(模拟器,文档)(这会使xcode在新下载后不再自动重新安装旧代码)。 虽然仍然找不到命令行工具的存放位置。 仍然崩溃。

尽管如此,应用程序仍然每秒或其他启动崩溃。

事情是直到最近的Xcode更新,我才没有问题。 可能是Xcode错误吗?

(编辑)我也正在运行最新的OSX开发人员版本。 会干扰吗?

First time I launch the app, everything seems to run fine.I’ll hit the stop button, do some work and when I go to launch it again, it seems to crash before it can even load anything.Press stop, hit Run again, and it works fine.Until I repeat the process.This is where xcode is highlighting the error with “Thread 1:signal SIGABRT”.Obviously nothing useful here.The debug console shows nothing besides (lldb) (So I suppose its stopping, not crashing at this point) So, when I perform a BT this is what I get:Here’s what I have done so far:Performed a ‘Clean’I’ve reset the simulators and reset my computerI’ve commented out all the code in the view controller, still crashesI’ve commented out all the code in the app delegate, still crashesBUT….I’ve run the app on a device outside of Xcode, and it seems to work perfectly fine.(EDIT) I’ve deleted/reinstalled xcode, and all content(Simulators, Docs) from the various cache folders (This stops xcode from automatically reinstalling the old ones after a new download).Still can’t find where command line tools is kept though.Still crashes.Despite all this, apps still crash every second/other launch.Thing is I had no issues until the most recent Xcode update.Could it be an Xcode bug?(EDIT) I am also running the latest developer releases of OSX.Could that be interfering?

问题:

当我将它上传到我的实际设备(iphone和iPad)时,我遇到了在iOS和Xcode上测试我的应用程序的问题,我想知道是否有人知道这个问题并且可以帮助我:

通常,当我在我的设备上构建我的应用程序时,应用程序将在我的设备上安装并启动。 但是当我准备提交我的第一个应用程序时,我正在测试并更改Bundle Identifier,App ID和Development Provisions(因此问题可能与它有关),现在,当我尝试构建我的应用程序时我的设备,虽然它在我的设备上安装得很好,Xcode将不再启动应用程序。 相反,我收到此错误消息:

启动可执行文件时出错。 启动远程程序时出错:没有此类文件或目录。

有谁知道这是什么问题? 这个派生数据文件夹是关于什么的?

非常感谢!

I ran into problem with testing my app on iOS and Xcode when I am uploading it to my actual devices (iphone and iPad), and I’m wondering if someone knows the issue and can help me out:Normally when I build my app on my devices, the app is installed and launched on my devices.But as I am preparing for submitting my first app I was testing around and changing the Bundle Identifier, App ID, and Development Provisions (so the issue may have something to do with it), and now, when I try to build my app on my devices, although it’s installed on my devices fine, Xcode will not launch the app anymore.Instead, I got this error message:Error Starting Executable.Error launching remote program: No such file or directory.Does anyone know what the issue is?And What is this derived data folder about?Much thanks!

问题:

我开发了在iPhone上运行完全正常的phonegap应用程序。 现在,我想将应用程序提交到appstore。 以下是我提交我的应用程序的步骤:

  1. 打开Xcode并将项目存档
  2. 单击验证(成功)
  3. 点击提交到应用商店(这是我收到以下错误的地方)

在此处输入图片说明

直到昨天晚上,我什至没有遇到这个错误,今天早上,我将项目存档了,并且得到了这个错误。 不知道是什么问题。

这是最后一个阶段,这使我无法提交应用程序,这非常令人沮丧,我试图在stackoverflow论坛上搜索相同的错误代码,而我找不到一条与我的错误代码完全相同的帖子,这很奇怪。

请帮忙 🙂

I have developed a phonegap application which is running absolutely fine on iPhone.Now, I want to submit the app to the appstore.Following is the procedure I am following to submit my app:Open Xcode and archive the projectClick on validate (which is successful)Click on Submit to appstore (which is where I am getting the following error)Until yesterday night, I wasn’t even getting this error and today morning, I archive the project and I get this error.Not sure what the issue is.This is the final stage which is stopping me from submitting the app and is very frustrating, I tried to search for the same error code on the stackoverflow forum and I could not find one single post which is exactly of the same error code as mine, which is very strange.Please help 🙂